有时安装好 FCPX 插件,发现预览窗口出现红色底、黄色叹号的错误提示的画面。

常见的几个原因

  • macOS系统、硬件更新,所安装的插件和当前的系统版本不兼容。(比如 M1,big sur,Monterey等)
  • FCPX 软件版本过低,所安装的插件和 FCPX 当前的版本不兼容。(和软件的正盗版没有关系)
  • 插件更名或者原件有素材缺失。(小概率事件)

首先,我们要判断红屏的原因。请查看自己的 Final Cut Pro 的版本和系统版本对照网站标明该插件的版本需求和系统需求

一般来说,高版本软件可以打开低版本插件。然而,系统过高却反而造成插件读取障碍。比如一些特效类的磨皮,跟踪,粒子,降噪等等。

*提醒:如果你的电脑是长期用来干活的生产力工具,请不要盲目更新升级!!

如果是软件版本低于插件的需求,那么可以重装高版本的软件。然而有时一个版本用习惯了,怕升级出什么岔子,那么也可以试试这个解决方法。

下面就让 FcpxBox.com 教大家修改插件的适配版本。

此方案不适用于所有的插件:可以解决大多数 FCPX 插件无法使用的情况,也有几率让陈年老插件起死回生,但无法解决 M1 或者系统大升级带来的插件故障。

用文本编辑器修改插件适配版本

先找到要修改的插件的安装位置,可以右键安装好的插件,点击 -> 在访达显示

这个方法不适用于所有的插件。如果没有这个选项的话,可以自行在访达中找插件。Final Cut Pro X模板存储在哪里

找到该插件,我们复制一个出来到桌面操作。右键打开方式,选择其他。

复制文件的意义有两个,一是强调下备份的重要性!!二是如果直接修改原文件,可能显示不是所有者/没有权限/锁定状态无法更改)

用文本编辑器打开它

可以看到这一大段代码。重要的是< ozml version >和< display version >

只需要将这两项修改成满足你的 FCPX 软件版本的对应版本号。下面的表格列表里有 FCPX 、 Motion 、 OZML vers 、Display vers 一一对应的版本号

FCPX 、 Motion 、 OZML vers 、Display vers 一一对应的版本号
FCPX 、 Motion 、 OZML vers 、Display vers 一一对应的版本号
fcpx ozml version

然后将修改好版本号的文件放回原插件安装位置,重启下 Final Cut Pro,OK啦!

那如果是系统版本过高(比如ARM M1),所安装的插件和当前的系统版本不兼容呢?

安装转译软件 Rosetta

有一些复杂特效的插件需 Rosetta 转译(并非原生支持M1):比如降噪插件 ProDenoise、擦除工具 FCPX Removal 等等。

如果您是 M1 芯片mac,在安装完插件后,依然出现红色不兼容提示。请关闭 Final Cut Pro 软件,并双击安装 FCPX_Rosetta2.app ,FCPX软件会自动打开并且即可正常运行。(每一次使用该插件都需要 Rosetta 转译)。

通过 Rosetta 2,搭载 Apple 芯片的 Mac 可以使用专为配备 Intel 处理器的 Mac 构建的 App。

如果还不能正常运行的话,目前就没有解决方法了。

再次提醒:如果你的电脑是长期用来干活的生产力工具,请不要盲目更新升级!!

声明: 本站文章未经许可禁止转载!本站仅供资源信息交流学习, 版权说明点此了解
0

评论0

请先

显示验证码
没有账号?注册  忘记密码?

社交账号快速登录